BlackBoard

Blackboard System Requirements

It is important that you are aware of the necessary requirements to run Blackboard smoothly before signing up for any course at Mount Royal that uses Blackboard, especially blended and online courses. These requirements are specifically for Blackboard but also apply to viewing videos and other course materials online.

Blackboard is only accessible through an Internet connection. It is dial-up, DSL and cable Internet-friendly. If possible do not use wireless internet when taking online exams.

Please note that at this time we do NOT recommend using an iPad to access Backboard courses. If you intend to take an online program you will need a desktop computer to do so.

What do I need on my computer?

  • An Internet connection. You must be connected to the Internet in order to access Blackboard and any online course materials. It is not a good idea to use public wireless Internet to connect to your Blackboard courses, especially if taking tests.
  • Google Chrome is the recommended browser. It is free and available for both Windows and Mac computers. We strongly recommend you do not use Internet Explorer or Safari. Please note that although Linux is not currently supported by Blackboard it has been shown to work with Blackboard and Google Chrome.
  • Adobe Flash Player
  • Java
  • Adobe PDF Reader

How do I find my computer's settings?

For Microsoft® Windows® computers, find your system settings:

  1. Click the Start button
  2. Click All Programs
  3. Select Accessories from the list (usually near the top)
  4. Select System Tools
  5. Click System Information

A new window will open with the details about your operating system version (OS Name), and other hardware such as your Hard Drive and Memory.

For Apple® Mac computera, find your system settings:

  1. Click the Apple icon (top left corner of the screen)
  2. Click About This Mac

A window will open displaying the version of your Mac, as well as other hardware such as the Processor and Memory.

Now that you know what type of computer you have, read below to see if it will be compatible with Blackboard.

 Compatibility with Blackboard

Below you will find the operating systems which are compatible with Mount Royal's version of Blackboard.

Microsoft® Windows® Operating System

  • Windows XP (32-bit)
  • Windows Vista (32-bit & 64-bit)
  • Windows 7 (32-bit & 64-bit)
  • Windows 8.1

Apple® Mac OS® Operating System

  • Mac OSX 10.6 Snow Leopard
  • Mac OSX 10.7 Lion
  • Mac OSX 10.8 Mountain Lion
  • Mac OSX 10.9 Mavericks
  • Mac OSX 10.10 Yosemite

 Accessibility and JAWS:

  • Blackboard strives to make all its products as accessible as possible. JAWS for Windows 11 and 12 were used during accessibility testing for SP9.

Technologies Not Supported:

The following technologies are not supported:

  • Internet Explorer 6, 7, 8
  • Firefox 1.x, 2.0, 3.0, and 3.5
  • Safari 2.0, 3.x and any version on Windows
  • Mac OSX 10.3, 10.4 Tiger
  • Max OSX 10.5 Leopard
  • Java 5, 6

Back to Blackboard Academic Suite